Relationship not working

Discuss HanDBase running on RIM BlackBerry devices and synchronization with a desktop.

Relationship not working

Postby mmedici » Sun Nov 15, 2009 10:54 pm

Hi all,

Trying to setup a somewhat simple database (actually 2).

there are 2 tables.
Table = Customers
Cust Name (Text) will always be unique
last contact date (relationship - getting last date from related orders date)
Balance (relationship - getting last total price from related orders)
Orders (link)

Table = Orders
Cust Name (Linked)
Date (date on add)
Price (float)
total price (calculated - adding price from this record to the total price from previous record)

From the desktop, all works fine, no issues.

From the Blackberry (curve), none of the relationships work.

Any ideas on why this is happening?

Thanks
Mike
mmedici
 
Posts: 3
Joined: Sun Nov 15, 2009 10:41 pm

Re: Relationship not working

Postby dhaupert » Mon Nov 16, 2009 10:54 am

Hi Mike,

Any chance you could send me a copy of the databases so I could test and debug on this end? If there is a bug there it would be a very quick way for me to find and fix it!
dhaupert
 
Posts: 4111
Joined: Tue May 26, 2009 11:51 am

Re: Relationship not working

Postby mmedici » Mon Nov 16, 2009 11:39 am

here you go. The fields are not named the same as I explained, but it is a very simple setup and I think you will get the gist. As I said, works fine on the desktop, just not on BBY.

thanks again.

mike
Attachments
Test DB.zip
(9.18 KiB) Downloaded 56 times
mmedici
 
Posts: 3
Joined: Sun Nov 15, 2009 10:41 pm

Re: Relationship not working

Postby mmedici » Wed Nov 18, 2009 10:12 pm

Dave,

Have you had a chance to test my DB out on a blackberry?

Thanks
Mike
mmedici
 
Posts: 3
Joined: Sun Nov 15, 2009 10:41 pm

Re: Relationship not working

Postby DavidDevaneyJr » Fri Nov 27, 2009 5:55 pm

mmedici wrote:Dave,

Have you had a chance to test my DB out on a blackberry?

Thanks
Mike


Dave Haupert asked me to take a look at these files today. I downloaded the file attached to your post but I'm not able to unzip it using either Unzip program I have. I'm not sure if it's due to what you zipped it with or if the upload to the forum corrupted it. Could you send the separate PDB files to ddevaney[at]ddhsoftware[dot]com and I will test with them to see if we can determine what the problem might be.
Regards,
David Devaney, Jr.
DavidDevaneyJr
 
Posts: 134
Joined: Tue May 19, 2009 11:01 pm
Location: Lake Worth, FL


Return to HanDBase for BlackBerry

Who is online

Users browsing this forum: No registered users and 2 guests

cron