problem loading forms into device

Discuss the HanDBase for Windows Desktop program, conduits, and add-ons.

problem loading forms into device

Postby rmdean10 » Thu Mar 03, 2011 10:46 am

So, I created a database and two forms on the desktop, now trying to get into device. Database appears to get on fine, and there is another file in the device called "....HDF.PDB". But when I open HandBase forms on the device (a trimble GeoXT running PPC) I don't see any forms. I of course am expecting this, because when I click save in the Forms Builder on the desktop I get this:
Error:

Unable to Install file "C...filepath to.....filename...HDF.PDB" to user: xt (Pocket PC)

Help!
rmdean10
 
Posts: 4
Joined: Thu Mar 03, 2011 10:39 am

Re: problem loading forms into device

Postby rmdean10 » Thu Mar 03, 2011 12:49 pm

well, actually they appear to be getting to device, non-withstanding the error message...


....but I end up with a problem viewing the forms because the text in them either doesn't show up, or shows up as a symbol-based font (though the source table does have the correct inputs from the keyboard....not that I would have known what I was writing).
rmdean10
 
Posts: 4
Joined: Thu Mar 03, 2011 10:39 am

Re: problem loading forms into device

Postby Brian_Houghton » Thu Mar 03, 2011 1:10 pm

Hi rmdean10,

First, the issue with the error about not being able to install the form files stems from not having the Files conduit enabled for your handheld. If you are using XP, enable the Files conduit in ActiveSync. If you are using Vista or 7, enable the Files conduit in Windows Mobile Device Center. After doing so you shouldn't see the error.

Essentially, the Files conduit syncs the "My Documents" folder from the Pocket PC to the computer. We just "piggy back" on this to install the form files.

Next, in regards to the issue with the fonts not showing properly, if you are seeing symbols where characters should be, there is a possibility that something might have become corrupted. Are you syncing with the files on the desktop or handheld open? If so, that could have been the cause! If the files on the desktop appear to be working properly, I'd delete the copies of the database and the form file from the My Documents\HanDBase folder on the Pocket PC. Use the File Explorer program to do this.

Then open the original database in HanDBase, select FIle -> Install, choose your partnership and click OK. You should see a prompt asking you if you want to install the form file. Agree to this. Then close the database and sync. The files should be installed to the Pocket PC.

After syncing, open HanDBase and check to see if the database and form work properly for you.
Kind Regards,
Brian Houghton, DDH Software
Brian_Houghton
 
Posts: 2246
Joined: Wed May 20, 2009 8:30 am

Re: problem loading forms into device

Postby rmdean10 » Thu Mar 03, 2011 1:47 pm

Flushing the system out like that seemed to solve the problem with the forms not going to the device correctly, but not the fonts as symbols.

Yet, I still cannot seem to solve one remaining problem. I am new to this, but I have searched your knowledge base and have not come up with a solution.

I believe there are supposed to be a few buttons along the bottom of the screen, such as "OK" "Cancel" "Details" "New"? Why are they not there?
rmdean10
 
Posts: 4
Joined: Thu Mar 03, 2011 10:39 am

Re: problem loading forms into device

Postby dhaupert » Fri Mar 04, 2011 9:50 am

Hi there,

Those buttons can be enabled via the Form details- you check which of them you'd like to see!
dhaupert
 
Posts: 4111
Joined: Tue May 26, 2009 11:51 am


Return to HanDBase for Windows

Who is online

Users browsing this forum: No registered users and 1 guest