Device reported 0 databases installed

Discuss plans for a future version of HanDBase for the Google Android platform

Device reported 0 databases installed

Postby cenzer » Fri Jun 16, 2017 4:34 am

Been getting this error when attempting to sync Galaxy S5 with Desktop running Windows 10.

Just arrived in Israel.

06-16-2017 12:26: Synchronizing with User: SM36
06-16-2017 12:26: HanDBase Professional for Android Add-on 4.6.2 Build R2
06-16-2017 12:26: Backing up new images on SM36...
06-16-2017 12:26: Error: Could not get list of images from device Code 200: HTTP/1.0 200 OK
06-16-2017 12:26: Backed up 0 images
06-16-2017 12:26: Backing up Forms on SM36...
06-16-2017 12:26: Getting Forms List
06-16-2017 12:26: Error: Could not get list of forms from device Code 200: HTTP/1.0 200 OK
06-16-2017 12:26: Backed up 0 forms files
06-16-2017 12:26: Error: Code 200: HTTP/1.0 200 OK
06-16-2017 12:26: Error: Device reported 0 databases installed. User cancelled sync when prompted
06-16-2017 12:26: Sync was Cancelled by User
06-16-2017 12:26: -----------------------------------------------------------------------------------
Thank you.

Charles
cenzer
 
Posts: 110
Joined: Tue Jul 21, 2009 12:54 am

Re: Device reported 0 databases installed

Postby Brian_Houghton » Sat Jun 17, 2017 8:03 am

Hi,

We have found that a recent update to some of the antivirus solutions available are causing HanDBase's connection to not work properly. Specifically, we have traced it to the free versions of Avast and AVG. With these titles installed and enabled (one of them), the HanDBase sync fails. If the antivirus is temporarily disabled, the sync works properly.

We are currently investigating what may have changed and will post an update once we have determined a solution. In the meantime, temporarily disable your antivirus to sync properly.
Kind Regards,
Brian Houghton, DDH Software
Brian_Houghton
 
Posts: 2248
Joined: Wed May 20, 2009 8:30 am

Re: Device reported 0 databases installed

Postby cenzer » Sat Jun 17, 2017 8:14 am

I turned off Avast for a hour and sync proceeded just fine.

Thank you for finding a solution

Charles Hart Enzer, MD
Thank you.

Charles
cenzer
 
Posts: 110
Joined: Tue Jul 21, 2009 12:54 am

Re: Device reported 0 databases installed

Postby griffinr » Mon Jul 10, 2017 4:41 pm

Just an update.

I received an update to my AVG a couple of days ago and my sync issues have been resolved. I no longer need to disable AVG to sync.
griffinr
 
Posts: 43
Joined: Thu May 21, 2009 6:32 am

Re: Device reported 0 databases installed

Postby ddhsoftwareadmin » Tue Jul 11, 2017 7:30 pm

Thanks so much for the update- I'm so relieved the problem seems to be taken care of!!
ddhsoftwareadmin
Site Admin
 
Posts: 346
Joined: Tue Dec 09, 2008 2:13 pm

Re: Device reported 0 databases installed

Postby KevinMillican » Sat Sep 08, 2018 4:08 pm

I am seeing this.

Synchronise worked fine the first day I used it. Now I get the same error:

09-07-2018 23:12: Synchronizing with User: Nokia
09-07-2018 23:12: HanDBase Enterprise for Android Add-on 4.7.7 Build R2
09-07-2018 23:12: Backing up new images on Nokia...
09-07-2018 23:12: No Forms on Device
09-07-2018 23:12: Backed up 0 images
09-07-2018 23:12: Backing up Forms on Nokia...
09-07-2018 23:12: Getting Forms List
09-07-2018 23:12: Got Forms List
09-07-2018 23:12: 2 forms in list
09-07-2018 23:12: Saved Form: E:\Documents\HanDBase\Nokia\Preheat_HDF.PDB
09-07-2018 23:12: Saved Form: E:\Documents\HanDBase\Nokia\Test_HDF.PDB
09-07-2018 23:12: Backed up 2 forms files
09-07-2018 23:12: Error: Code 200: HTTP/1.0 200 OK
09-07-2018 23:12: Error: Device reported 0 databases installed. User cancelled sync when prompted
09-07-2018 23:12: Sync was Cancelled by User

I have tried letting Synchronise through the Windows firewall.
Also tried turning off my Windows antivirus (F-Secure)

No effect.

On the Android phone, Sync reports that it has sent Images, Databases, and Forms.

Any ideas?
KevinMillican
 
Posts: 4
Joined: Sat Sep 08, 2018 3:52 pm

Re: Device reported 0 databases installed

Postby ddhsoftwareadmin » Sun Sep 09, 2018 10:42 am

Hi,

Thanks for writing. As you can see above, the solution for this has typically been disabling the anti-virus. Are you sure there is no chance you have multiple A/V apps running?
ddhsoftwareadmin
Site Admin
 
Posts: 346
Joined: Tue Dec 09, 2008 2:13 pm

Re: Device reported 0 databases installed

Postby KevinMillican » Mon Sep 10, 2018 5:22 pm

ddhsoftwareadmin wrote:Hi, Thanks for writing. As you can see above, the solution for this has typically been disabling the anti-virus. Are you sure there is no chance you have multiple A/V apps running?


Thanks for your quick reply.
I am running Windows 10
I have F-Secure running, but it has reported no events. I also tried with security disabled and it made no difference.
Windows Defender is switched off and I have no other AV installed.
I can't see anything in my Windows system or application logs.

I ran synchronise in administrator mode but the result was the same.
The synchronise did work OK the first time I used it. I have not made any changes to security since then.

If I visit the web page using the link (http://my-android-phone-address:8280) I can see and download all the databases.

Are there any other more detailed Handbase logs hidden away anywhere I could check?
KevinMillican
 
Posts: 4
Joined: Sat Sep 08, 2018 3:52 pm

Re: Device reported 0 databases installed

Postby KevinMillican » Tue Sep 11, 2018 11:34 am

After some fiddling about, I have managed to get three databases syncing.
Complete failure before may be related to a form being left on the Android device after the database was deleted.

Here is a new log (extra line breaks inserted for clarity) :-
09-11-2018 17:26: Synchronizing with User: Kevin-Nokia-6.1
09-11-2018 17:26: HanDBase Enterprise for Android Add-on 4.7.7 Build R2
09-11-2018 17:26: Backing up new images on Kevin-Nokia-6.1...
09-11-2018 17:26: No Forms on Device
09-11-2018 17:26: Backed up 0 images
09-11-2018 17:26: Backing up Forms on Kevin-Nokia-6.1...
09-11-2018 17:26: Getting Forms List
09-11-2018 17:26: Got Forms List
09-11-2018 17:26: No Forms on Device
09-11-2018 17:26: Backed up 0 forms files

09-11-2018 17:26: Database: Materials Sync Mode: Synchronize
09-11-2018 17:26: Synchronizing Database: Materials...
09-11-2018 17:26: Getting Android Database To Sync with Desktop: Materials...
09-11-2018 17:26: Getting Android Database To Sync with Desktop: Materials...OK
09-11-2018 17:26: Syncing with Desktop Database: Materials...
09-11-2018 17:26: Syncing with Desktop Database: Materials...OK
09-11-2018 17:26: File not Changed: Materials...


09-11-2018 17:26: Database: Parameters Sync Mode: Synchronize
09-11-2018 17:26: Synchronizing Database: Parameters...
09-11-2018 17:26: Getting Android Database To Sync with Desktop: Parameters...
09-11-2018 17:26: Getting Android Database To Sync with Desktop: Parameters...OK
09-11-2018 17:26: Syncing with Desktop Database: Parameters...
09-11-2018 17:26: Syncing with Desktop Database: Parameters...OK
09-11-2018 17:26: Saving Changes to Android Device: Parameters...
09-11-2018 17:26: Sending Parameters.PDB to device..
09-11-2018 17:26: Saving Changes to Android Device: Parameters...OK


09-11-2018 17:26: Database: People Sync Mode: Do Nothing

09-11-2018 17:26: Database: Positions Sync Mode: Synchronize
09-11-2018 17:26: Synchronizing Database: Positions...
09-11-2018 17:26: Getting Android Database To Sync with Desktop: Positions...
09-11-2018 17:26: Getting Android Database To Sync with Desktop: Positions...OK
09-11-2018 17:26: Syncing with Desktop Database: Positions...
09-11-2018 17:26: Syncing with Desktop Database: Positions...OK
09-11-2018 17:26: File not Changed: Positions...


09-11-2018 17:26: Database: Preheat Sync Mode: Synchronize
09-11-2018 17:26: Synchronizing Database: Preheat...
09-11-2018 17:26: Getting Android Database To Sync with Desktop: Preheat...
09-11-2018 17:26: Error: Code 200: HTTP/1.0 200 OK
09-11-2018 17:26: Getting Android Database To Sync with Desktop: Preheat...Error:Ó


09-11-2018 17:26: Database: Processes Sync Mode: Synchronize
09-11-2018 17:26: Synchronizing Database: Processes...
09-11-2018 17:26: Getting Android Database To Sync with Desktop: Processes...
09-11-2018 17:26: Error: Code 200: HTTP/1.0 200 OK
09-11-2018 17:26: Getting Android Database To Sync with Desktop: Processes...Error:Ó


09-11-2018 17:26: Database: Customer List Sync Mode: Do Nothing
09-11-2018 17:26: Database: EZShop Sync Mode: Do Nothing
09-11-2018 17:26: Database: Movie JukeBox Sync Mode: Do Nothing
09-11-2018 17:26: Database: Password Keeper Sync Mode: Do Nothing
09-11-2018 17:26: Database: Time Billing Sync Mode: Do Nothing
09-11-2018 17:26: Database: Time Billing Detail Sync Mode: Do Nothing
09-11-2018 17:26: Sync Complete
09-11-2018 17:26: -----------------------------------------------------------------------------------

If I use the web interface to download or upload the PDB files that won't sync, they work fine in either direction.
KevinMillican
 
Posts: 4
Joined: Sat Sep 08, 2018 3:52 pm


Return to HanDBase for Android

Who is online

Users browsing this forum: No registered users and 1 guest