Page 1 of 1

Displaying an image from a linked db

PostPosted: Mon Sep 08, 2014 3:57 am
by Alanwestwood
Hi guys, I think I need some help/advice in displaying images from related/linked files in my designed forms.

I have a db which is related to a second one and looks up a match from a text field to load the image library source from the second db, and then displays the image from the second file on a form in the first file. Using a picture field with the related field as the image source it works just fine.

But, I'd rather use a link than a relationship, so that the child db displays the image from the parent db. But having set up the link to fetch the image library text form the parent record (which displays fine on a form in the parent) I simply cannot get the image to display in the child record. The child record displays the correct text for the image library in the linked field, but if I use the linked field as the image source for a picture field it doesn't display the image. I can't understand why, because a) it works fine if the image source is a related field, and b) the image is displayed fine in the parent record.

Any idea what I'm doing wrong?

Cheers, Alan.

Re: Displaying an image from a linked db

PostPosted: Mon Sep 08, 2014 5:26 am
by Brian_Houghton
Hi Alan,

The value imported by the relationship is treated as text, so therefore the external field (which relies on a text field) works. Values imported by links are not treated as text, hence the problem you are encountering.

Due to this I have to recommend using the relationship field type.

Re: Displaying an image from a linked db

PostPosted: Mon Sep 08, 2014 7:15 am
by Alanwestwood
Ok Brian, got that, thanks. I can do a workaround where I have a link and a relationship, so thats fine. Because I can display the linked field as 'apparent text' in a button, I assumed that it could be used as such, but I did notice that I can't put it in a text box so kind of guessed what you have described.

Many thanks for the quick reply.

Cheers, Alan.

Edit (later) - yep, got that working fine, thanks again :-)