Problems using form to open form in second db

Discussions for the HanDBase for iPad and it's conduits and desktop add-ons

Problems using form to open form in second db

Postby Beejay » Sun Dec 14, 2014 2:45 pm

Hi,
I have been using forms on my ipad and have hit a problem when using a form on one database to open a form in another. It sometimes works but on other occasions it corrupts data in one of the fields of the second database. It is possibly something I am doing so I will try to describe what I am doing.
The first database only has one field and is used to select an airmans name from a third database (called airmen). The id of this airman is stored in the single field.
The second database (called crews) has records each of which contains the airman ids of each crew member on a particular mission. Each of these records has a relationship field to the id of the first database. In other words each record in the second database now contains this same id. This is used to compare with with each crew member to set a flag to be used in a view that shows all the missions this airman flew on.
Since I can't directly compare the relationship field with the crew ids I have created a second conditional field which basically contains the relationship id to compare with the crew ids.
What is happening is that if I select an airman in the first database then open the second database the selected airman appears and there is no problem. If I then try to use a form in the first database to open a form in the second database it sometimes does not work and corrupts a field in the second database. When you examine the fields in the second database the relationship fields are correctly updated but the conditional fields have not been updated. It's as if the the second database has not had time to update all the fields before the form is opened.
I cannot see any command to force the the second database to recalculate.
Sorry to be so long winded, I hope the above is understandable. If you need any more information please let me know.
Beejay
 
Posts: 4
Joined: Sat Nov 15, 2014 2:58 pm

Re: Problems using form to open form in second db

Postby Brian_Houghton » Mon Dec 15, 2014 6:51 am

Hi,

Thanks for posting.

Sorry to read of the issue you are experiencing.

We have not encountered any such problems nor have we had any reports until yours.

If possible, could you send me a copy of your databases and form files so that we can test with them to see if there is a configuration issue or a bug we have not discovered? If you can send me the files please send them to support @ ddhsoftware . com along with a brief reminder of what issue you are needing checked.
Kind Regards,
Brian Houghton, DDH Software
Brian_Houghton
 
Posts: 2246
Joined: Wed May 20, 2009 8:30 am


Return to HanDBase for iPad

Who is online

Users browsing this forum: No registered users and 1 guest

cron