Page 1 of 1

Moving forms?

PostPosted: Sun Feb 05, 2017 2:18 pm
by glenwf
I created a database with a form on an iPod Touch and tried to transfer it to an iPod Mini (the first one).

I used the Desktop Connect on my iPod and using Safari on the Mini got the database on the Mini. No Form got transferred. Doesn't Desktop Connect transfer forms????

So I then emailed it from the iPod to the Mini and was successful transferring both database and form.

I saw the need to change the form, so after fixing, I emailed it to the Mini, but now I can't update the form. When it says copy to HanDBase, it goes to HanDBase, but nothing happens.

Deleted the database and the form on the Mini, and tried the email route again. This time neither the database or the form will be copied to the Mini.

How do I get over this problem? Desktop Connect doesn't copy forms, and email is somehow broken the transfer of the files to the Mini.


Re: Moving forms?

PostPosted: Tue Feb 07, 2017 9:22 pm
by ddhsoftwareadmin
Hi there,

Sorry for the delay in responding. The forms file is available on desktop connect- there are three icons next to a database when there is a form included in it, the rightmost one is the one to download the forms file. It's also a .PDB file but it has the name: Database Name_HDF.PDB where Database Name is the name of the database it goes with. By the same token you can install forms via desktop connect, just choose that file to upload instead of the main database.

I'm not sure what is happening with the other route you tried- that should definitely work, but perhaps there is a bug there- something I will check into!

Re: Moving forms?

PostPosted: Wed Feb 08, 2017 12:39 pm
by glenwf
Tried again to transfer the forms via Desktop Connect from iPhone to iPad and iPad Mini.

On the iPad, I had already installed the database, so I tried to transfer the form (I forgot about what that other icon was - sorry). Selecting the form icon, it asks where to send it and I select HanDBase. It goes to HanDBase, but the download screen never comes up and nothing gets transferred.

On the iPad Mini, I had not installed the database, so with Desktop Connect I try to serve from the iPhone to Mini with the browser on the Mini. Success on the Mini, I get the download window and the database is transferred. So, I go back to the browser on the Mini and try to download the form. Click on the form, it asks where to send it and I select HanDBase, and it switches to HanDBase, but the download window doesn't come up.

Many experiments occur and I find the same frustrating problem. Now it won't even transfer a new database. I'm thinking there is a bug somewhere because this is happening on both the iPad and the iPad Mini. Can't transfer anything to either of the iPads. I'm thinking maybe if I delete and reinstall HanDBase, I can start the cycle over again, but I doubt it. What do you think.