Cannot open app on iPod Touch

Discussion of the version of HanDBase that runs on the iPhone and iPod touch devices. This includes the synchronization conduits as well.

Cannot open app on iPod Touch

Postby schmidty » Tue Jun 30, 2009 3:53 pm

I just recently switched from a palm OS to iPod touch (software version 2.2) with HanDbase. It worked great for several days but now all of a sudden the application won't open on the iPod. The loading screen comes on and then it just goes back to the iPod homescreen. No error message. Is this a problem with the iPod or the app? I've tried resetting the iPod several times to no effect. I would really like to get the data that was stored in HanDbase so haven't tried restoring iPod. Any suggestion from this end? I appreciate any insight. Thanks!
schmidty
 
Posts: 1
Joined: Tue Jun 30, 2009 3:44 pm

Re: Cannot open app on iPod Touch

Postby dhaupert » Tue Jun 30, 2009 4:26 pm

schmidty wrote:I just recently switched from a palm OS to iPod touch (software version 2.2) with HanDbase. It worked great for several days but now all of a sudden the application won't open on the iPod. The loading screen comes on and then it just goes back to the iPod homescreen. No error message. Is this a problem with the iPod or the app? I've tried resetting the iPod several times to no effect. I would really like to get the data that was stored in HanDbase so haven't tried restoring iPod. Any suggestion from this end? I appreciate any insight. Thanks!


This is one I have not seen before, and it's very troubling because the only real way to get the databases from the application is by running it, due to the way the data for an app is restricted to only be accessible from the app itself (and the root OS, which may be how we work around it). Actually in the version we first released, this was possible because of our app, because if a database was somehow corrupted and the program kept trying to reopen it, you'd see this happening. But I added in a check- if the previous attempt to restore your position in a database fails, on the next launch, go to the choose database screen. So it is not likely our app in this case, at least as far as I've experienced!

I was looking for some clues on the net and saw this posting:
http://reviews.cnet.com/8301-19512_7-10115709-233.html

Guess it's happened before, though that was an older article from last summer. That solution was to wipe everything off the device and start over- not much of a solution ;)

Here's another with some more promising things to try:
http://www.ipodtouchfans.com/forums/sho ... hp?t=89024

In particular, perhaps you can delete an app or two and retry. It may be related to something external to the app.
They also mentioned syncing to your desktop and making sure to eject the device when you disconnect. Try a few of those and let me know if that works.

If it doesn't work, deleting the app and reisntalling from the app store may be the next step, but of course the data will be lost. that said, if you are up for the work, you can work around this by running a program on your desktop that can parse the backup files that iTunes make. Those files are a big compressed archive file and there are programs to decode these backups and let you grab individual files from them. Here's an article on the forum that discusses these:
viewtopic.php?f=3&t=77

I'd try that after trying the previous steps though, as it would be great to fix this without going through all those pains!
Let me know how you make out.
dhaupert
 
Posts: 4111
Joined: Tue May 26, 2009 11:51 am


Return to HanDBase for iPhone and iPod touch

Who is online

Users browsing this forum: No registered users and 1 guest