frozen, hung

Discussion of the version of HanDBase that runs on the iPhone and iPod touch devices. This includes the synchronization conduits as well.

frozen, hung

Postby glenwf » Wed Dec 25, 2013 3:03 pm

Added some new files, selected a view, then got the view but now I have a static screen. Nothing happens if I select anything including Home, new, view, configure, or any record. I can hit the iPod 5 button and get out of HanDbase, and the iPod5 works fine, but when I go back in the same screen is there.

What do I do now? Lately, it has seemed buggy (HanDBase, not my iPod5) while typing with pauses, odd things happening and I had to quit editing on the iPod it got so bad, erasing stuff I typed, etc.

Anyway, how do I get back to functionality?

OOPS, now all my records disappeared from my screen, but the note at the bottom says it is in the same view as before. Still can't get back to home & move to another database.

Latest HanDBase version (can't check to see the version)
iOS 7.0.4

Thanks.
glenwf
 
Posts: 167
Joined: Wed May 20, 2009 5:34 pm
Location: Roseville, CA

Re: frozen, hung

Postby glenwf » Wed Dec 25, 2013 3:44 pm

I tried completely turning off the iPod5 and back on after 10 minutes. Now it seems to be working properly.

I'm guessing the cause was fragmented memory that the complete turn off and on reset.

Thanks for listening..
glenwf
 
Posts: 167
Joined: Wed May 20, 2009 5:34 pm
Location: Roseville, CA

Re: frozen, hung

Postby Brian_Houghton » Thu Dec 26, 2013 11:48 am

Hi Glen,

Thanks for writing. Glad that you are back in operation.

Regarding the odd behaviors you are experiencing in HanDBase, can you elaborate more on a sequence of steps that cause these delays/hangs? Please note whether it is relative to one specific database, a specific field type, when using forms or not, etc. The more variables you can isolate the better we can determine the cause.

Sent from my Nexus 7 using Tapatalk HD
Kind Regards,
Brian Houghton, DDH Software
Brian_Houghton
 
Posts: 2246
Joined: Wed May 20, 2009 8:30 am

Re: frozen, hung

Postby glenwf » Thu Dec 26, 2013 5:42 pm

Sure, I'll note a few things that were odd. They aren't happening anymore, but they were interesting and not related to any database, but I think they were happening only in HanDBase (can't promise that).

1. Slowly got worse. Hit any button "Home", "New Record", "Configure" and nothing would happen - wait - give up, and hit another button and the first button would activate. Like, hit new record - nothing - hit configure and I would get the new record. Or, like hit home and nothing would happen - wait - hit new record and Home would activate. ETC.

2. While editing a record.
Hit keys, nothing happens, hit it again and I get all the alternate configurations of it as if I was holding down the "a" key until the alternate versions of "a" appear.
Hit the "back up" key to delete a letter, wait - try again, nothing, then type something and all of a sudden my whole editing would disappear as the curser deleted to the left until the beginning all by its self.

The above #2 kinda sounds like sticky keys of some variation.

These conditions slowly got worse over a few days (turning it off many times during that time and always at night).

Access Within Apps is set "on"
Twitter & Facebook turned "off"

Can't think of anything else that might have an affect on the behavior of HanDBase.
Hope that helps you.
glenwf
 
Posts: 167
Joined: Wed May 20, 2009 5:34 pm
Location: Roseville, CA

Re: frozen, hung

Postby Brian_Houghton » Sat Dec 28, 2013 9:48 am

Thanks for the update, Glen. We will be checking for these.

Sent from my Nexus 7 using Tapatalk HD
Kind Regards,
Brian Houghton, DDH Software
Brian_Houghton
 
Posts: 2246
Joined: Wed May 20, 2009 8:30 am


Return to HanDBase for iPhone and iPod touch

Who is online

Users browsing this forum: No registered users and 1 guest

cron