Page 1 of 1

Bugs on iphone version?

PostPosted: Mon Oct 15, 2018 7:21 am
by franco
iPhone 7 - iOS 12 - HandBase 4.9.079

Field type "External -> Camera" is not working for me. I take a picture and select "use photo", but it won't select anything. Field remains blank.

Re: Bugs on iphone version?

PostPosted: Mon Oct 15, 2018 1:32 pm
by ddhsoftwareadmin
Hi there,

Thanks for writing. Do you have a text field assigned and configured within the external field setup to store the image?

Please send a screenshot or share the settings you have within your external field's settings.

Re: Bugs on iphone version?

PostPosted: Mon Oct 15, 2018 1:49 pm
by franco
Is it correct?

Re: Bugs on iphone version?

PostPosted: Fri Oct 19, 2018 8:58 pm
by ddhsoftwareadmin
Hi,

Thanks for posting the screenshots. All looks ok from the pics you sent- one possibility is that the max text for the text field isn't big enough to hold the image file name. Please make sure to make the image file name field have a max characters of something high (eg, 250 characters) and try again.

If that doesn't work, let me know!

Re: Bugs on iphone version?

PostPosted: Sat Oct 20, 2018 8:05 am
by curtterp
I did some testing with my iPhone Xs Max.

I was able to throw together a quick database with a test field and external field for the camera. I was able to use both front and rear camera for the photo field with no issues.

I then reduced the character length to 10 and tried again. When I took the picture, I got a warning popup saying that the text field length was not long enough and I should increase it to at least 37 characters. No Image shows up. Put the length back to 60 (default) and it works again.

I then took away the HanDBase permissions to the camera. When I chose the camera, all I get is a black screen and the shutter button does not work.

Put the camera settings to most compatible, and it still works.

I even tried the database on my iPad which has iOS12.1 Beta 3 on it and that still works.

In short, I was not able to recreate the issue without having a warning message.

Re: Bugs on iphone version?

PostPosted: Mon Oct 22, 2018 9:06 am
by franco
Just created another database (same settings) and now it works. Don't know why.
Thanks for the attention!

Re: Bugs on iphone version?

PostPosted: Thu Oct 25, 2018 9:13 am
by franco
Dave, i've found the cause. I'm brazilian and in portuguese we use characters like "ú, ç, ê, ã. The name of my database was "Eleições", so the name of the image file was "Eleições_imgiPhone 7 de Franco000001.jpg". The software won't work with those characters and that is the problem. I renamed the image file from "Eleições_imgiPhone 7 de Franco000001.jpg" to "Eleicoes_imgiPhone 7 de Franco000001.jpg" and the photos showed up. I renamed the database from "Eleições" to "Eleicoes", so all file names will be generated without special characters and everything is ok now. Never had problems like this before with your software, but it's the first time I tried to use the camera within a field.