Fields disappear from some views!!!

Discussion of the version of HanDBase that runs on the iPhone and iPod touch devices. This includes the synchronization conduits as well.

Fields disappear from some views!!!

Postby mluka » Mon Oct 19, 2009 4:55 pm

Hi all.

HanDBase version 4.3.0 (just updated from some previous version, but the problem appeared with the previous version); iPod software version 3.0.

I was using a database and all of a sudden, some fields, which are normally visible in some views, are now invisible!!!

One of the fields is a "check-box", the other a "text" field (the item description, actually).

These fields are visible in some of the views, but not in others.

I've checked the Views themselves in the "Database Properties" and can see absolutely nothing that would explain this behaviour.

I must emphasize that I've been using this database for months (almost a year, actually), have made no change at all since I first started using it and this behaviour appeared SUDDENLY.

The only "weird" thing that I noticed is that just as I started using the database today, I must have rotated the iPod and the DB changed orientation (from portrait to landscape).

Otherwise, this change appeared by itself!

Any clues as to the cause for this behaviour and ideas for correction???

Thanks!
mluka
 
Posts: 4
Joined: Mon Oct 19, 2009 4:39 pm

Re: Fields disappear from some views!!!

Postby dhaupert » Tue Oct 20, 2009 11:08 pm

Hi there,

Thanks for your posting. So far, when this problem happens, it typically turns out that the customer didn't realize that the right to left swipe or the left to right swipe scrolls left and right fields at a time in the List view. If that is the case, perhaps you can try a flick in the list view from left to right and see if any fields re-appear? Let me know!
dhaupert
 
Posts: 4111
Joined: Tue May 26, 2009 11:51 am

Re: Fields disappear from some views!!!

Postby mluka » Fri Oct 23, 2009 6:35 pm

Right on, Dave. That's exactly what the problem was! I must have swiped when the iPod went "horizontal". Thanks for your help!
mluka
 
Posts: 4
Joined: Mon Oct 19, 2009 4:39 pm


Return to HanDBase for iPhone and iPod touch

Who is online

Users browsing this forum: No registered users and 1 guest

cron