Strange Sync Error Windows to iPad

Discuss the HanDBase for Windows Desktop program, conduits, and add-ons.

Strange Sync Error Windows to iPad

Postby uboche » Sun Jan 26, 2014 6:18 am

With the last sync between HanDBase on Windows and my iPad the log showed an error that puzzles me. Here are the relevant log lines:

01-24-2014 21:55: Database: Windows D/US/NL Sync Mode: Synchronize
01-24-2014 21:55: Synchronizing Database: Windows D/US/NL...
01-24-2014 21:55: Getting iPhone/iPad Database To Sync with Desktop: Windows D/US/NL...
01-24-2014 21:55: Getting iPhone/iPad Database To Sync with Desktop: Windows D/US/NL...OK
01-24-2014 21:55: Syncing with Desktop Database: Windows D/US/NL...
01-24-2014 21:55: Syncing with Desktop Database: Windows D/US/NL...OK
01-24-2014 21:55: Saving Changes to iPhone: Windows D/US/NL...
01-24-2014 21:55: Sending Windows_D_US_NL.PDB to iPhone/iPad..
01-24-2014 21:55: Error: Code 200: HTTP/1.1 200 OK
01-24-2014 21:55: Saving Changes to iPhone: Windows D/US/NL...Error: 0Ý
01-24-2014 21:55: Sync Complete
01-24-2014 21:55: -----------------------------------------------------------------------------------

I had made a few changes the the Windows version of the database which are all present in the iPad version after the sync. Nothing appears to be wrong with the database. The HTTP error code (200) is the normal code you would expect if everything goes well, so where and what is the problem?
Regards,
Ulrich Boche
uboche
 
Posts: 130
Joined: Wed May 20, 2009 1:52 pm

Re: Strange Sync Error Windows to iPad

Postby uboche » Thu Jan 30, 2014 5:00 am

The error that I reported in my previous post has returned, but with a different database. Here are the relevant log lines:

01-30-2014 10:49: Database: Acronyms Sync Mode: Synchronize
01-30-2014 10:49: Synchronizing Database: Acronyms...
01-30-2014 10:49: Getting iPhone/iPad Database To Sync with Desktop: Acronyms...
01-30-2014 10:49: Getting iPhone/iPad Database To Sync with Desktop: Acronyms...OK
01-30-2014 10:49: Syncing with Desktop Database: Acronyms...
01-30-2014 10:49: Syncing with Desktop Database: Acronyms...OK
01-30-2014 10:49: Saving Changes to iPhone: Acronyms...
01-30-2014 10:49: Sending Acronyms.PDB to iPhone/iPad..
01-30-2014 10:49: Error: Code 200: HTTP/1.1 200 OK
01-30-2014 10:49: Saving Changes to iPhone: Acronyms...Error: 0Ý

It appears that this error appears with any database that is changed on the Windows desktop. However, the synchronization is OK and the changes are present on the iPad.
My HanDBase Desktop version is 4.7.5, I updated today to the HanDBase Professional iPhone/iPad Add-on V.4.7.7 Build R1 but that did not change the situation in any way.

PS. The strange accented "Y" after the error code "0" is 'DD'x followed by '18'x
Regards,
Ulrich Boche
uboche
 
Posts: 130
Joined: Wed May 20, 2009 1:52 pm

Re: Strange Sync Error Windows to iPad

Postby Brian_Houghton » Thu Jan 30, 2014 6:20 am

Hi,

Sorry to read of this error. I have a couple of questions to help us understand what is occurring:

1. When syncing, is the desktop copy of the database closed?
2. When no changes are made on the desktop, does the sync occur without error?
3. After you make the changes to the database on the desktop, and save it, do you choose to reinstall the database when prompted?
4. Does this issue affect only these two databases, or does it affect others?
5. When you make edits on the iPad, do they sync to the desktop without issue?

Sent from my Nexus 7 using Tapatalk HD
Kind Regards,
Brian Houghton, DDH Software
Brian_Houghton
 
Posts: 2246
Joined: Wed May 20, 2009 8:30 am

Re: Strange Sync Error Windows to iPad

Postby uboche » Thu Jan 30, 2014 5:19 pm

Did some further testing to be able to answer your questions with confidence. Here are the answers:

1. Yes
2. The error appears with all databases changed on the desktop or on the iPaD
3. Yes
4. It affects any database that is changed. However, the synchronization itself is working, all databases are intact and all changes are synchronized.
5. See above. Same error.

This problem appears only since a few days. Are you using the C runtime library from Microsoft?
Regards,
Ulrich Boche
uboche
 
Posts: 130
Joined: Wed May 20, 2009 1:52 pm

Re: Strange Sync Error Windows to iPad

Postby uboche » Wed Feb 05, 2014 6:46 am

I asked about the C Runtime Library because of problems I had at the same time with the installation of iTunes 11.1.4. This update failed to install leaving me without a working iTunes program and a C Runtime library error message after each boot. But I restored my C-drive now from backup and everything is working again. Only the HanDBase sync error is still there, so it is unrelated to that problem.

Additional information:
Today I changed a form for a database (E-Nummern) with HanDBase for Windows. This caused the following lines in the log file:

02-05-2014 12:39: Synchronizing with User: iPad von uboche
02-05-2014 12:39: HanDBase Professional for iPhone/iPad Add-on 4.7.6 Build R1
02-05-2014 12:39: Installing File: D:\\HanDBase\iPadvonuboche\Install\E-Nummern_hdf.PDB...
02-05-2014 12:39: Sending E-Nummern_hdf.PDB to iPhone/iPad..
02-05-2014 12:39: Error: Code 200: HTTP/1.1 200 OK
02-05-2014 12:39: Installing File: D:\\HanDBase\iPadvonuboche\Install\E-Nummern_hdf.PDB...Error: äã6ŸH

The changed form installed correctly on the iPad.

To me this looks a little bit like a mismatch between the return code field you expect from the HTTP tool you're using and the actual field that is returned.
Regards,
Ulrich Boche
uboche
 
Posts: 130
Joined: Wed May 20, 2009 1:52 pm

Re: Strange Sync Error Windows to iPad

Postby Brian_Houghton » Sun Feb 09, 2014 10:58 am

The error is indicating that there is a temporary communication problem between the handheld and computer. It might be of help for you to reboot your wireless router, as this sometimes clears up connection issues. In order to reboot the router, simply unplug the power from it, wait about a minute and then plug the power back into it.

Let us know if the issue recurs after doing this.

Sent from my Nexus 7 using Tapatalk HD
Kind Regards,
Brian Houghton, DDH Software
Brian_Houghton
 
Posts: 2246
Joined: Wed May 20, 2009 8:30 am

Re: Strange Sync Error Windows to iPad

Postby uboche » Mon Feb 10, 2014 6:15 am

I upgraded my Fritz!Box router two days ago with the newest firmware version. I also have other devices communicating with my PC over the LAN/WLAN network without any problem. I doubt very seriously that this is a communication problem. Doesn't a HTTP 200 message indicate that the communication went fine? Apart from the strange error message I get during sync, no data gets lost in the communication, all updates are ok.
Regards,
Ulrich Boche
uboche
 
Posts: 130
Joined: Wed May 20, 2009 1:52 pm

Re: Strange Sync Error Windows to iPad

Postby Gab-Hop » Mon Feb 10, 2014 3:35 pm

Hi
I had a similar problem to this
And found that if i went and deleted all the DBs from one side (ether desktop or device)
and then copied them back over from the copy i had kept
the issue was resolved
There seemed to be something in the structure of one that was not compatable with the other it was syncing with
Note; first make sure the one you are going to use is working well

Sometimes i get the Error HTTP 200 message if my conection was lost or interupted part way through the sync
and in the log all DBs after that point will have a strange error after them
Gab-Hop
 
Posts: 45
Joined: Mon Jan 13, 2014 11:34 pm
Location: New Zealand

Re: Strange Sync Error Windows to iPad

Postby uboche » Tue Feb 11, 2014 7:53 am

Today I made a copy of all database and form files on the PC and deleted all databases from the iPad. The next sync moved the HanDBase files on the PC to the archive and I then began to reinstall the HanDBase files on the PC from the copied files. The files install fine but I don't get rid of the sync errors. What should I do to get to a clean start?

02-11-2014 13:39: Synchronizing with User: iPad von uboche
02-11-2014 13:39: HanDBase Professional for iPhone/iPad Add-on 4.7.6 Build R1
02-11-2014 13:39: Installing File: D:\\HanDBase\iPadvonuboche\Install\Acronyms.PDB...
02-11-2014 13:39: Sending Acronyms.PDB to iPhone/iPad..
02-11-2014 13:39: Error: Code 200: HTTP/1.1 200 OK
02-11-2014 13:39: Installing File: D:\\HanDBase\iPadvonuboche\Install\Acronyms.PDB...Error: äæ6ŸH
02-11-2014 13:39: Installing File: D:\\HanDBase\iPadvonuboche\Install\Albert_Heijn.PDB...
02-11-2014 13:39: Sending Albert_Heijn.PDB to iPhone/iPad..
02-11-2014 13:39: Error: Code 200: HTTP/1.1 200 OK
02-11-2014 13:39: Installing File: D:\\HanDBase\iPadvonuboche\Install\Albert_Heijn.PDB...Error: äæ6ŸH
02-11-2014 13:39: Installing File: D:\\HanDBase\iPadvonuboche\Install\Australian.PDB...
02-11-2014 13:39: Sending Australian.PDB to iPhone/iPad..
02-11-2014 13:39: Error: Code 200: HTTP/1.1 200 OK
02-11-2014 13:39: Installing File: D:\\HanDBase\iPadvonuboche\Install\Australian.PDB...Error: äæ6ŸH
02-11-2014 13:39: Installing File: D:\\HanDBase\iPadvonuboche\Install\E-Nummern.PDB...
02-11-2014 13:39: Sending E-Nummern.PDB to iPhone/iPad..
02-11-2014 13:39: Error: Code 200: HTTP/1.1 200 OK
02-11-2014 13:39: Installing File: D:\\HanDBase\iPadvonuboche\Install\E-Nummern.PDB...Error: äæ6ŸH
02-11-2014 13:39: Installing File: D:\\HanDBase\iPadvonuboche\Install\E-Nummern_hdf.PDB...
02-11-2014 13:39: Sending E-Nummern_hdf.PDB to iPhone/iPad..
02-11-2014 13:39: Error: Code 200: HTTP/1.1 200 OK
02-11-2014 13:39: Installing File: D:\\HanDBase\iPadvonuboche\Install\E-Nummern_hdf.PDB...Error: äæ6ŸH
02-11-2014 13:39: Backing up new images on iPad von uboche...
02-11-2014 13:39: Backed up 0 images
02-11-2014 13:39: Backing up Forms on iPad von uboche...
02-11-2014 13:39: Saved Form: D:\\HanDBase\iPadvonuboche\E-Nummern_HDF.PDB
02-11-2014 13:39: Backed up 1 forms files
02-11-2014 13:39: Database: Acronyms Sync Mode: Synchronize
02-11-2014 13:39: Synchronizing Database: Acronyms...
02-11-2014 13:39: Getting iPhone/iPad Database To Sync with Desktop: Acronyms...
02-11-2014 13:39: Getting iPhone/iPad Database To Sync with Desktop: Acronyms...OK
02-11-2014 13:39: Syncing with Desktop Database: Acronyms...
02-11-2014 13:39: Syncing with Desktop Database: Acronyms...OK
02-11-2014 13:39: Saving Changes to iPhone: Acronyms...
02-11-2014 13:39: Sending Acronyms.PDB to iPhone/iPad..
02-11-2014 13:39: Error: Code 200: HTTP/1.1 200 OK
02-11-2014 13:39: Saving Changes to iPhone: Acronyms...Error: 0Ý
02-11-2014 13:39: Database: Albert Heijn Sync Mode: Synchronize
Regards,
Ulrich Boche
uboche
 
Posts: 130
Joined: Wed May 20, 2009 1:52 pm

Re: Strange Sync Error Windows to iPad

Postby uboche » Wed Feb 12, 2014 4:24 am

This morning, I deleted the iPad user in the sync menu and established a new user account with the "Setup New iPhone User" button. Then I installed the first database from backup and this is the result:

02-12-2014 10:16: Synchronizing with User: iPad von uboche
02-12-2014 10:16: HanDBase Professional for iPhone/iPad Add-on 4.7.6 Build R1
02-12-2014 10:16: Backing up new images on iPad von uboche...
02-12-2014 10:16: Backed up 0 images
02-12-2014 10:16: Backing up Forms on iPad von uboche...
02-12-2014 10:16: Not Found: The Page being requested does not currently exist on the Server
02-12-2014 10:16: Backed up 0 forms files
02-12-2014 10:16: Not Found: The Page being requested does not currently exist on the Server
02-12-2014 10:16: Sync Complete
02-12-2014 10:16: -----------------------------------------------------------------------------------
02-12-2014 10:18: Synchronizing with User: iPad von uboche
02-12-2014 10:18: HanDBase Professional for iPhone/iPad Add-on 4.7.6 Build R1
02-12-2014 10:18: Installing File: D:\\HanDBase\iPadvonuboche\Install\Acronyms.PDB...
02-12-2014 10:18: Sending Acronyms.PDB to iPhone/iPad..
02-12-2014 10:18: Error: Code 200: HTTP/1.1 200 OK
02-12-2014 10:18: Installing File: D:\\HanDBase\iPadvonuboche\Install\Acronyms.PDB...Error: äQ
02-12-2014 10:18: Backing up new images on iPad von uboche...
02-12-2014 10:18: Backed up 0 images
02-12-2014 10:18: Backing up Forms on iPad von uboche...
02-12-2014 10:18: Not Found: The Page being requested does not currently exist on the Server
02-12-2014 10:18: Backed up 0 forms files
02-12-2014 10:18: Database: Acronyms Sync Mode: Synchronize
02-12-2014 10:18: Synchronizing Database: Acronyms...
02-12-2014 10:18: Getting iPhone/iPad Database To Sync with Desktop: Acronyms...
02-12-2014 10:18: Getting iPhone/iPad Database To Sync with Desktop: Acronyms...OK
02-12-2014 10:18: Syncing with Desktop Database: Acronyms...
02-12-2014 10:18: Syncing with Desktop Database: Acronyms...OK
02-12-2014 10:18: File not Changed: Acronyms...
02-12-2014 10:18: Sync Complete
02-12-2014 10:18: -----------------------------------------------------------------------------------

What can I do to get back to normal?
Regards,
Ulrich Boche
uboche
 
Posts: 130
Joined: Wed May 20, 2009 1:52 pm

Next

Return to HanDBase for Windows

Who is online

Users browsing this forum: No registered users and 0 guests

cron