Forms lost after move to new phone

Discussion of the version of HanDBase that runs on the iPhone and iPod touch devices. This includes the synchronization conduits as well.

Forms lost after move to new phone

Postby glenwf » Wed Jul 03, 2019 11:32 am

Got a new iPhone and after installing the HanDBase, I used the desktop sync with the following setting:
"One Way Sync Desktop Records to iPhone only"

Now I have all my databases, but the forms were missing and I had to add the Forms app which I did.

Did the same above again, but my forms are still not there.

How do I get my forms from my desktop (MacBook Pro-El Capitan) backup to my new iPhone 6S.
Desktop HanDBase = 4.512
glenwf
 
Posts: 197
Joined: Wed May 20, 2009 5:34 pm
Location: Roseville, CA

Re: Forms lost after move to new phone

Postby glenwf » Wed Jul 03, 2019 12:41 pm

I discovered when I synced my iPhone 6s with iTunes, and looked at the File Sharing apps, and looked at HanBBase, all the files including the forms are on my iPhone. But if I look at any database that has an associated form, that forms list library for that file is empty.

So, how do I get the database to see the form? I'm lost without the forms.
glenwf
 
Posts: 197
Joined: Wed May 20, 2009 5:34 pm
Location: Roseville, CA

Bug?

Postby glenwf » Thu Jul 04, 2019 1:11 pm

Sadly, nobody replied, but then it is a holiday.

I solved it, although it took an hour. The brute force solution to get the database to recognize the form that was already there was to replace it with a Desktop Connect link from my old phone and using Safari on my new phone, connect to the old phone and retrieve each form (not the database) one by one.

Interestingly though many files have forms associated with them that have no forms designed for them. Grabbed them anyway in case I was remembering wrong. Also, each form grabbed transferred 6 files:
databasename.HDF.PDB
hdbiphonelogo.jpg
iphonedl_sm.gif
dicsv.gif
forms.gif
ddhlogo.gif

I'm thinking there is a problem with the "One Way Sync, Desktop to iPhone" - maybe a bug??? When was the last time this was tested???
glenwf
 
Posts: 197
Joined: Wed May 20, 2009 5:34 pm
Location: Roseville, CA


Return to HanDBase for iPhone and iPod touch

Who is online

Users browsing this forum: No registered users and 0 guests

cron